myGully.com

myGully.com (https://mygully.com/index.php)
-   Spiele Diskussionen (https://mygully.com/forumdisplay.php?f=495)
-   -   Train Simulator (alle Versionen) Problem- und Diskussionsthread (https://mygully.com/showthread.php?t=3137907)

Schooltrain 11.08.16 18:45

Zitat:

Zitat von master891 (Beitrag 28797508)
Habe heute festgestellt das im Railworks Menü:

Das bei Schnelles Spiel/Zugverbände/Neu erstellen bei 18 % RW abstürzt.
Kann keine Zugverbände mehr erstellen. :dozey:

..

Wahrscheinlich hast Du nun inzwischen zu viele Routes im Folder Content. Ich schrieb ja schon mehrfach, dass die Scenario Database des TS limitiert ist. Da hilft nur splitten. Probier das mal. Ist ja relativ einfach. Mach nen Hilfsordner mit z.B "Content Nr2" und kopiere einfach die Hälfte Deiner Routes d hinein. Wenn die verbliebene im Original "Content" fehlerfrei läuft, vertauschst Du beide durch entsprechende Umbenennung. Der TS nimmt immer nur "Content" als relevanten Ordner für die Routes. Wenn diese Experiment ohne Fehler funktioniert, ist der Grund für den Absturz bewiesen: Scenario Database zu gross. Also umorganisieren.

Sollte das nicht abhelfen, dann ist irgenwas anderes faul. Aber Du hast dann wenigstens nichts versaut oder glöscht .

Schooltrain 11.08.16 21:14

Dazu muss man die Listung der Dump Datei aber erstmal verstehen. Dort wird so viel Zeug aufgelistet, das auch den NORMAFALL betrifft.

"Irgendwas mit Assets" zu löschen kann man natürlich machen. Das halte ich aber für ziemlich mühselig und sogar gefährlich, wenn man sich dabei vertut.

Übrigens werden die Assets vom TS nur nach dem Bedarf der geladenen Strecke durchsucht. Beim Start des TS wird die Scenario Database aufgebaut. Dafür ist nur der Content Ordner wichtig. Wenn der TS beim Programstart dabei z.B. notwendige Assets nicht findet, ist ihm das schnurz. Das wird erst beim Laden der Strecke später bemerkt und ggf angemeckert oder einfach nicht angezeigt.
Kann aber aus irgendeinem Grund die Scenario Database nicht richtig aufgebaut werden, kommt es u.U. zu Abstürzen mit oder ohne Dump.

Das wirklich gemeine dabei ist, dass der TS in gewissen Grenzfällen zwar trotzdem richtig startet, aber dann später auf Probleme stösst. Das passiert immer, wenn seine Database überfordert ist. Und das genau passiert, wenn zu viele Routes vorhanden sind. Sowas kam früher ja kaum vor. Wer kauft schon mehr als 100 Routes ? Aber heute ist das schon möglich. Ich weiss gar nicht, wie viele ich eigentlich habe. Aber ich sorge immer dafür, dass nicht mehr als 100 geladen werden.

Daher würde ich bei der Untersuchung erstmal mich auf den Content konzentrieren mit den Routes.

Immernicht 12.08.16 10:59

Zitat:

Zitat von Schooltrain (Beitrag 28797562)
Sollte das nicht abhelfen, dann ist irgenwas anderes faul. Aber Du hast dann wenigstens nichts versaut oder glöscht .

Wird nicht helfen, denn was haben die Häusle, Bäumle, Zäunle und Rollis mit dem Verzeichnis Content zu tun? Alle Objekte werden von der Route und den Szenarien aufgerufen und platziert. Oft sogar während des Spiels.

Denkbar ist ein völlig zermurkstes Objekt. Das muss nicht einmal ein Rolli sein, über was Railworks stolpert. In erster Linie trifft das auf lose-Dateisammlungen zu. Ist von denen eine betroffen, dann gute Nacht: Format Railworks-Partition.

Ich weiss ja nun nicht wie weit dein auspacken aus den *.AP-Paketen fortgeschritten ist und ob diese *.ap's noch existieren. Ich habe da hier auf diesem Brett mal ganz merkwürdige Diskussionen gelesen. Falls du sie noch alle besitzt, kannst du vielleicht mit RW-Tools noch etwas retten, in dem du alle Rollis noch einmal auspackst und die vorhandenen aus den AssetPacks überschreibst. Das betrifft aber nur die Rollis aus den AssetPacks.

Ansonsten hilft dir nur die Weiterarbeit mit der Version, die du augenblicklich verwendest. C'est la vie. Und wenn du diese Version wieder aufrüstest, dann hüte dich vor ungeprüften losen Dateisammlungen. Kannst mir ja mal eine Wunschliste der eventuell betroffenen Rollis in *.rwp-Verpackung schicken. :p

Ich habe aber auch noch nicht heraus gefunden, in welchem Verzeichnis oder Datei die eigenen Zuggarnituren geschrieben werden. Eine XML-Datei kann es nicht sein, denn die werden von mir regelmäßig gelöscht.

Schooltrain 12.08.16 14:49

Zitat:

Zitat von Immernicht (Beitrag 28800587)
Wird nicht helfen, denn was haben die Häusle, Bäumle, Zäunle und Rollis mit dem Verzeichnis Content zu tun? Alle Objekte werden von der Route und den Szenarien aufgerufen und platziert. Oft sogar während des Spiels.
................

Du hast noch nicht richtig verstanden was ich meinte.

Er (nicht ICH) muss ja erst mal eingrenzen, wo der Fehler eigentlich liegt. Dazu dient mein Vorschlag mit dem Aufsplitten des CONTENT. Denn wenn er inzwischen sehr viele Strecken hat, ist es nur eine Zeitfrage, bis die Database Probleme undefinierter Art macht. Und das gilt fuer JEDEN hier mit mehr als ca 100 Routes im Content (die Zahl ist nicht genau zu bestimmen).
Wenn das Aufsplitten nichts bringt, muss er sich tatsaechlich anders rantasten. Aber warum nicht einfach anfangen, wenn es auch kompliziert geht, gell?

Und nochmals: Bei mir laeuft alles perfekt mit Win10, der neuesten Version des TS und ca 300 routes. Allerdings erst nachdem ich vor mehr als einem Jahr bereits die Probleme mit der Scenario Database erkannte und beseitigte.
Die Assets spielen dabei NULL Rolle. Da koennen so viel drin sein wie es gefaellt. Mein TS ist mittlerweile ca 300GB gross. Davon sind ein Grossteil der Assets in .ap Dateien gepackt. Sonst waere das Ding noch groesser. Trotzdem laeuft alles perfekt. Nur beim Erst-Start des TS dauert es schon mal ein bisschen. Eben wegen des Aufbaus der Datenbank. Aber kein Abbruch oder sonstwas.

Und auch das nochmals: Es gibt manche Strecken (gerade bei der Freeware, aber nicht nur da), die laden auf Deibel komm raus Material von anderen Strecken zu ihren eigenen Objekten noch dazu. Da kommt man auf richtig Platzbedarf, und der TS belegt weit mehr als die paar GB, die er mit 32Bit bearbeiten kann. Ohne 64Bit System und MEHR als 4GB Speicher wird das dann nichts mehr!

Und ein weiterer Tip: Wer unbedingt RWP Fateien erstellen will, macht am besten folgendes: Bilde 3 der gewuenschten Folder Assets, Content und Manuals und stelle sie separat mit ihrem von Dir geplanten Inhalt. Dann bilde mit 7-Zip ein Archive im Zip Format. Das ergibt eine Datei mit Erweiterung .zip

Die .zip einfach in .ap umbenennen und fertig ist die Laube.

Auf diese Art und Weise kann man die von DTG gelieferten Dateien sogar richtig PACKEN. Denn die werden zwar im ZIP Format geliefert, sind aber 1:1 "gepackt" - also GARNICHT !

master891 12.08.16 14:54

Absturz im Zugeditor
 
So habe jetzt einmal die Daten von der alten Sicherung in den Assets-Ordner
geschoben und siehe da, jetzt der Fehler vorhanden der vorher nicht war.
Hier stürzt Railworks im Zugeditor bei 20 % ab.

Also hat es mit dem Content-Ordner und Anzahl der Routen nichts zu tun.

Also bevor meine Strecken nicht mehr laufen, verzichte ich lieber auf den
Zugeditor. Kann man ja auch noch zum Glück anderst erstellen.

Wäre auch ein mühsames SUCHEN.

Danke trozdem

Nachtrag Fehler gefunden:

Nachdem es mir keine Ruhe lies, habe ich den Assets Ordner nach Datum der Daten einmal überprüft und bin fündig geworden!
Es war ein Repaint von Agilis im Ordner DTG BR440 Pack01
Nach dem LÖSCHEN des Repaints ist jetzt wieder alles OK.




:T:T

Schooltrain 12.08.16 15:13

Zitat:

Zitat von master891 (Beitrag 28801599)
S.........
Also bevor meine Strecken nicht mehr laufen, verzichte ich lieber auf den
Zugeditor. Kann man ja auch noch zum Glück anderst erstellen.

Wäre auch ein mühsames SUCHEN.

Danke trozdem

:T:T

Na soooo muehsam ja auch wieder nicht. Es gibt ja Freeware zum Datei-Vergleich. Und wenn Du eine Version hast, die laeuft, sollte man den Unterschied zur nichtlaufenden Version ja finden koennen.

Ich weiss sowieso nicht, WAS Du zum Schluss gemacht hast. Hast Du die (laufende) Assets-Sicherung einfach auf den NICHTlaufenden Assets Ordner geschoben ??

Jonas28 12.08.16 16:10

Grafikeinstellungen TS 56,4b
 
Früher hatte ich einen schwachen Intel Core i3 4130 CPU
mit AMD Radeon R240 Grafik mit 2 GB DDR3 Speicher und 8 GB Ram.
Ich konnte den TS nur auch Niedrig stellen das es flüssig lief.
Nur bei Niedrig ist alles unscharf und teilweise fehlen bei einigen
aufwendigeren Strecken sogar ganze Bahnsteige oder Dächer.

Das wollte ich ändern und kaufte mir einen Gamer PC.

Intel Core i5 6600k 4x bis zu 3,9 GHZ
16 GB DDR4 Ram 2400 MHZ
SSD HDD 240 GB
1 GB HDD 7200 rpm
Nvidia GTX 960 4 GB DDR5
Windwos 10

TS 56,4b gecrackt auf SSD installiert

Habe nun die Grafik auf Hoch gestellt und die dann vorhandenen Grafikeinstellungen
die von TS dann vorgesehen sind so gelassen.

Ich habe dann erst einmal nur alle deutschen Strecken installiert.
Und alle deutsche Loks und Züge die ich habe.
Mein TS umfasst nun etwa 45 GB

Gerade in großen Bahnhöfen wie Hamburg oder Köln ruckt und zuckt es trotzdem teilweise sehr stark. Das darf doch nicht wahr sein.
was mache ich falsch oder habt ihr einen Tipp für mich, dass bei Einstellung Hoch alles ruckelfrei läuft.
das bei einer Fahrt von 60 Minuten es 2-3 kleine Nachladeruckler gibt ist ja normal, dass meine ich nicht.

Schooltrain 12.08.16 17:41

Zitat:

Zitat von Jonas28 (Beitrag 28801837)
,,,,,,,,,,,,,
Gerade in großen Bahnhöfen wie Hamburg oder Köln ruckt und zuckt es trotzdem teilweise sehr stark. Das darf doch nicht wahr sein.
was mache ich falsch oder habt ihr einen Tipp für mich, dass bei Einstellung Hoch alles ruckelfrei läuft.
das bei einer Fahrt von 60 Minuten es 2-3 kleine Nachladeruckler gibt ist ja normal, dass meine ich nicht.

Schwer zu sagen aus der Ferne.

Dein System ist sicher schnell genug. Man müsste mal in den Task Manager gucken. Unter Performance kannst Du sehen wie die Speicherbelegung ist. Und was für Prozesse sonst noch laufen, die vielleicht CPU Zeit "stehlen".
Du hast SSD Drives. Sonst hätte ich gesagt, Du müsstest mal defragmentieren.

Dabei fällt mir ein: Wenn der TS mit seinem Speicher nicht mehr auskommt, wird ge-SWAPT wie bei jedem anderen Program. Es stehen ihm wahrscheinlich für sein 32-Bit Program sowieso nur etwas mehr als 3GB zur Verfügung. Da lohnt es sich, Windows einen grossen Swap Bereich FEST zuzuweisen. Das könnte was bringen.

Dann nochmals Grafikkarten-Einstellungen und Treiber checken. Wenn da was nicht stimmt, kann es arg ruckeln.
Gerade solche Bahnhöfe stellen mit ihren Oberleitungen und sonstigen Objekten hohe Anforderungen.

Schooltrain 12.08.16 17:45

Zitat:

Zitat von master891 (Beitrag 28801599)
...................
Nachtrag Fehler gefunden:

Nachdem es mir keine Ruhe lies, habe ich den Assets Ordner nach Datum der Daten einmal überprüft und bin fündig geworden!
Es war ein Repaint von Agilis im Ordner DTG BR440 Pack01
Nach dem LÖSCHEN des Repaints ist jetzt wieder alles OK.




:T:T

Ja, ja ... diese Repaints :rolleyes: Da sind manchmal ganz schöne Dilettanten am Werk.

master891 12.08.16 18:53

Jonas28

Habe nun die Grafik auf Hoch gestellt und die dann vorhandenen Grafikeinstellungendie von TS dann vorgesehen sind so gelassen.

----

Hallo Jonas,

ich habe einen i7 4790K der mit 4,4 Ghz läuft. Meine GK ist eine GT960 mit 4 GB
und 16 GB Ram Arbeitsspeicher.
Habe RW extra und allein auf einer 480 GB SSD Festplatte installiert.
Ich habe meine GK Einstellungen auch auf hoch und bei mir läuft RW mit
allen Strecken flüssig (außer ab und zu die Miniruckler).


:T:T

AByu 12.08.16 22:12

Hat jemand von RW/0381 die DR-Doppelstockwagen auf der Platte rumschmoren? Mir fehlt da fast alles! Danke schonmal! Wie immer: gerne Tausch

Immernicht 13.08.16 10:18

Zitat:

Zitat von Schooltrain (Beitrag 28802155)
Ja, ja ... diese Repaints :rolleyes: Da sind manchmal ganz schöne Dilettanten am Werk.

Es gibt eine einfache Regel: Repaints sollten erst dann installiert werden, wenn in Routen oder Szenarien ein Bedarf angemeldet ist. In diesem Fall kann man davon ausgehen, dass das Rolli vorher schon mehrfach installiert und geprüft wurde. Weiterhin wird euch nicht erspart in die zum Angebot gehörenden Kommentare zu schauen oder mal das Rail-Sim-Forum abzufragen. Da kommen oft erstaunliche Dinge ans Tageslicht.

Ludmilla233 13.08.16 14:35

Zitat:

Zitat von master891 (Beitrag 28805971)
Immernicht

PS: Hat schon einer die Freeware-Strecke die Niederelbebahn (KBS 121) installiert
und damit Erfahrungen gemacht. Lohnt sich die Strecke ?

:T:T

Ja habe und zwar eine gute Strecke aber es gibt ein paar gravierende Fehler. Diese Fehler werden aber in einem Update von jemanden ausgebessert

TrainspottingSuedWest 13.08.16 14:49

Hat wer München - Rosenheim?

AByu 13.08.16 16:36

Danke @master891.
Die beiden anderen (DBvu&DBvq) gabs schon mal im Angebotstread! War da leider im Urlaub und die sind mir somit entgangen :( Hätte die noch mal wer für mich?
Immernoch: Gerne im Tausch

AByu 13.08.16 21:59

Danke, kann es sein, dass Datein beim Upload fahlgeschlagen sind? Die Blau beigen Dostos sind voll mit Missing Texture.. Fehlt dir aktuell, in sachen Rollis etwas?

Immernicht 14.08.16 11:03

Zitat:

Zitat von TrainspottingSuedWest (Beitrag 28806117)
Hat wer München - Rosenheim?

Du hast eine PN!

phli2008 14.08.16 11:43

Danke an @AByu für die VR Sammlung :-)

@Alle: Am besten schnell downloaden, Virtual Railroads ist seit neustem fleißig am abusen. Wird warscheinlich schon Dienstag, spätestens Mittwoch down sein. :-(

Immernicht 14.08.16 12:14

Zitat:

Zitat von Schooltrain (Beitrag 28797528)
Überzeugen würde mich ja, wenn es auch noch Quer- und Kreuzverweise brächte, WO die einzelnen Komponenten im gesamten Spiel gebraucht werden. Das macht es aber nicht!

Deine Äußerung trifft nicht auf kommerzielle Strecken zu, weil diese lt. Steam-Vorgabe grundsätzlich alle benötigten Assets mitbringen und diese grundsätzlich auf eigenem Mist gewachsen sein müssen. Es gibt noch andere Vorschriften, aber die spielen in dem Fall keine Rolle.

Ich habe vor einiger Zeit schon mal eine Sammlung aller Häusle, Bäumle und sonstwas-le zusammen gestellt, die von den freien Streckenbauern benutzt werden. Musst mal im Angebotsthread ebissl zurück blättern.
[Link nur für registrierte und freigeschaltete Mitglieder sichtbar. Jetzt registrieren...] und [Link nur für registrierte und freigeschaltete Mitglieder sichtbar. Jetzt registrieren...]
Ich bin aber auch gern bereit diese Sammlung in den nächsten Tagen zu aktualisieren. Viel Neues gibt es nicht, höchstens die Häusle aus Polen wurden verbessert und ein paar Brücken aus CS kamen hinzu.

Man kann die Pakete auf zweierlei Weise verwenden:
1. TS-Neulinge können die RWP-Datei installieren und haben auf einem Schlag alles was sie von Usedom über Freiberg bis Felberpass benötigen. Sie brauchen sich also um die lange Liste der Freewarebauern nicht kümmern und müssen nur die Rollis suchen, die benötigt werden. Diese Liste ist bei den meisten Streckenbauern ähnlich

2. Sollte auf Grund der Tatsache, das eine ältere Freeware-Strecke (nur um die geht es) mal mit Utilities deinstalliert wurde und nun paar Assets fehlen, kann der Anwender die RWP mit einem Dateimanager öffnen und den gesamten Inhalt innerhalb weniger Sekunden und auf einem Schlag ins Programmverzeichnis kopieren. Damit wäre dieses Kritik erledigt.

Bei den freien Streckenbauern hat sich weiterhin durchgesetzt, das die Häusele, Bäumele, Zäunele und Brückele in externen Paketen zusammengefasst werden, so das sie bei der Deinstallation der eigentlichen Strecke im Verzeichniss ..\Assets\.. verbleiben. Das war übrigens auch eine Forderung der Rail-Sim Community. Vorbildlich gelöst ist das zum Beispiel in "Steam on the Sierra".

Insider verwenden zur Deinstallation einer Freeware-Strecke oder eines überflüssigen/fehlerhaften Szenarios eh nur noch die RW-Tools.

AByu 14.08.16 13:14

Ich hab noch Links von ner ganzen Kollektion da, allerdings gebe ich diese nur an vertrauenswürdige Personen weiter, da ich kein bock habe das ganze zu Reuppen!

Stalin 14.08.16 14:35

Hat einer von euch evlt die Fahrzeit 28 [Link nur für registrierte und freigeschaltete Mitglieder sichtbar. Jetzt registrieren...] am start?

Immernicht 14.08.16 14:38

Zitat:

Zitat von AByu (Beitrag 28810474)
Ich hab noch Links von ner ganzen Kollektion da, allerdings gebe ich diese nur an vertrauenswürdige Personen weiter, da ich kein bock habe das ganze zu Reuppen!

Häähhh? Das iss woll nischt.:rolleyes:

AByu 14.08.16 15:19

Zitat:

Zitat von Immernicht (Beitrag 28810786)
Häähhh? Das iss woll nischt.:rolleyes:

? Ich stelle das nicht als Öffentlichen link einfach so rein, weil die wenigsten, dass noch Brauchen! So ist die warscheinlichkeit, dass die Pakete Offline Gehen deutlich kleiner! Sollte jemand ne vR Sammlung brauchen kann er sich gerne via PN Melden!

Nochmal ne kleine frage: Hat jemand die RPP Updatepacks für die 425 installiert (funktionerend). Die kann ich, aus unerklärlichen Gründen, nicht Installieren. Ich bitte euch mir jetzt nicht zusagen, dass ich das ganze in den Orginal RW Ordner dafür verschieben muss, dass habe ich nämlich schon getan! Gerne im Tauch!

Jürgen14 14.08.16 18:29

Hat jemand den Railjet Advanced
Danke im voraus :T

Immernicht 14.08.16 19:04

Zitat:

Zitat von Jürgen14 (Beitrag 28811616)
Hat jemand den Railjet Advanced
Danke im voraus :T

Ich habe hier das 3LänderEck&SBB1&Railjet in den Versionen von Aerosoft und RWA. Alles in einem Paket von knapp 3,5 GByte.

Herunter laden und einfach freuen. Ok?

phli2008 14.08.16 19:33

Hat zufällig jemand die Strecken München-Rosenheim und Mannheim-Karlsruhe auf der Platte und kann sie zur Verfügung stellen?

Wäre toll.

ich hätte ne Sammlung von TaD. wisst ihr wie es bei denen mit Abuses aussieht?


Lg Philipp

Immernicht 15.08.16 10:41

Abuse haben hier in mygully weniger Einfluss, sehr wohl aber auf einige Hoster. Es ist immer ratsam entweder kryptische Dateinamen zu verwenden oder sich ein kostenloses Account bei mega.nz anzulegen.

Rosenheim ist hier mit drin:

master891 15.08.16 13:29

AByu

Nochmal ne kleine frage: Hat jemand die RPP Updatepacks für die 425 installiert (funktionerend). Die kann ich, aus unerklärlichen Gründen, nicht Installieren.:::

-----
Dir fehlt wahrscheinlich die AP Datei im Ordner.
OK dann mußt du es manuell machen und das geht so:

Im Update Ordner nimmst du z.B die Datei 425 mit TTB 432 Ki Sound
Dann gehst du in den Ordner data. Darin befinden sich 4 zip. Dateien.
Die enpackst du jetzt alle zusammen in einen Ordner.
Jetzt hast du im Ordner Audio und RailVehicles.
Die kopierst du jetzt in den Ordner DTG\RhineValley1\und lässt alles überschreiben.

Aber mache vorher eine Sicherung falls Probleme gibt !!!!

PS: Habe das Update mit dem Morphy Sound installiert und die 425 im schnellen Spiel Altenburg-Wlidenau probiert klappt hier einwandfrei.


:T:T

Mr. Price 15.08.16 14:56

Moinsen Jungs,

kann mir jemand sagen ob die Strecke "Hamburg-Hannover" auch im TS2016 läuft ?
Wenn ja wäre es super wenn diese jmd uploaden könnte ;-)

Grüße & danke im Voraus !

master891 15.08.16 16:59

Mr. Price

kann mir jemand sagen ob die Strecke "Hamburg-Hannover" auch im TS2016 läuft ?
---------------------------------------

Aber natürlich funktioniert die Strecke auch im TS 2016 !!!

:T:T

AByu 15.08.16 17:34

Zitat:

Zitat von Mr. Price (Beitrag 28815316)
Moinsen Jungs,

kann mir jemand sagen ob die Strecke "Hamburg-Hannover" auch im TS2016 läuft ?
Wenn ja wäre es super wenn diese jmd uploaden könnte ;-)

Grüße & danke im Voraus !

Guck verammt noch mal im Addons Thead dort ist HH-H angeboten und der Downlaod funktioniert meine ich!


@Master Wärst du so lieb und Lädst miir den Ordner inmal hoch? bei mir will das nicht :(

AByu 15.08.16 17:36

@Master, auf diese weise Probiert.. Kannst du mir dass kurz Uploaden? Danke!

AByu 15.08.16 20:56

Dange!

Jonas28 15.08.16 23:01

Hat jemand die Railtraction BR 628-4 für mich da?
Die 628-2 habe ich.

Stalin 16.08.16 12:50

nochmal in die runde: hat jemand [Link nur für registrierte und freigeschaltete Mitglieder sichtbar. Jetzt registrieren...] für die vR Version? :)


Alle Zeitangaben in WEZ +1. Es ist jetzt 20:31 Uhr.

Powered by vBulletin® (Deutsch)
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.